Archive

Archive for the ‘Networking’ Category

tcpdump – manuale rapido

January 15th, 2019 No comments

tcpdump è un tool comune per il debug delle reti di computer che funziona da riga di comando. Consente all’utente di intercettare pacchetti e trasmissioni sulla rete al quale il computer è collegato

il comando  può essere usato con i seguenti parametri:

-i : ascolta solo su un’interfaccia (es:-i eth0) o tutte (es: -i any)
-n : non risolve i nomi.
-nn : non risolve sia nomi che porte.
-X : mostra il contenuto dei pacchetti sia in esadecimale che in ASCII
-v-vv-vvv : incrementa il numero delle infomazioni.
-c : mostra solo un certo numero di pacchetti (es: -c 10).
-S : stampa la sequenza di numeri assoluti
-e : ottiene l’header.
-q : mostra poche informazioni sul protocollo.
-w nomefile: salva l’output in un file. Utile per poter essere analizzato successivamente. Aperto con wireshark, per esempio, può fornire informazioni più dettagliate e comprensibili

 

Le opzioni che non necessitano di un parametro possono essere raggruppate. Per fare un esempio:
tcpdump -i eth0 -nnXvvSeq -c 10

Per visualizzare quello di cui abbiamo effettivamente bisogno possono essere eseguiti diversi tipi  filtri. Di seguito qualche esempio

    • host // mostra solo il traffico di un certo IP (funziona anche con un nome host ma non bisogna usare l’opzione -n)
      tcpdump host 1.2.3.4
    • src, dst // mostra solo il traffico della sorgente o della destinazione
      tcpdump src 2.3.4.5
      tcpdump dst 3.4.5.6
    • net // mostra il traffico di un’intera rete
      tcpdump net 1.2.3.0/24
    • proto // funziona solo per tcp, udp e icmp.
      tcpdump icmp
    • port // mostra solo il traffico di una certa porta
      tcpdump port 3389
    • src, dst port // filtro basato su porta sorgente e destinazione
      tcpdump src port 1025
      tcpdump dst port 3389

 

Altri esempi più complessi:

Tutto il traffico del protocollo tcp originato da 10.5.2.3 destinato alla porta 3389
tcpdump -nnvvS tcp and src 10.5.2.3 and dst port 3389

Tutto il traffico originato dai due IP che non abbia come destinazione la porta 22
tcpdump -vv src 10.10.10.1 or 10.10.10.2 and not dst port 22

Categories: Articolo Tecnico, Networking Tags:

Come verificare un server NTP utilizzando ‘ntpdate’

January 15th, 2019 No comments

Per verificare se un server NTP è vivo e risponde alle richieste NTP o per controllare manualmente un server NTP per vedere se l’orologio è corretto si può usare ntpdate da una CLI di Linux per interrogare il server NTP.

$ ntpdate -q pool.ntp.org
server 64.71.128.26, stratum 2, offset 1.552116, delay 0.06792
server 104.236.236.188, stratum 2, offset 1.556884, delay 0.11574
server 108.59.2.24, stratum 2, offset 1.569006, delay 0.11952
server 209.114.111.1, stratum 2, offset 1.542965, delay 0.11389
19 Apr 21:30:06 ntpdate[32062]: step time server 64.71.128.26 offset 1.552116 sec

L’opzione -q interroga solo, e non impostare l’ora.

Se i server ntp sono già configurati su ntp.conf usare il comando;

ntpq -pn

Installare sipcalc su Mac OSX

November 28th, 2018 No comments

Informazioni generali

Installazione

  1. Premi Command+Space digita Terminal e premi il tasto enter/return
  2. Nel terminale scrivi:
    ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)" < /dev/null 2> /dev/null
    e premi il tasto enter/return
    Se lo schermo ti chiede di inserire una password, inserisci la password utente del tuo Mac per continuare
  3. Digita:
    brew install sipcalc

Fatto! Ora puoi usare  sipcalc

Articolo originale: http://macappstore.org/sipcalc/

Scaricare video da Internet

March 5th, 2018 No comments

Spesso ci capita di voler scaricare alcuni video da Internet (Facebook, Youtube, blog di amici), come fare?

Ci sono diverse applicazioni ed estensioni per il browser oltre che molti servizi online che consentono di scaricare video da Internet in maniera estremamente facile e veloce anche per i meno esperti. Per ciascuna delle metodologie elencate vi indicherò la soluzione a mio avviso più efficace

ApplicazioneJDownloader (scarica da qui la versione per Windows o MAC OSX)

Una volta installata l’applicazione e lasciata in esecuzione sarà sufficiente  collegarsi alla pagina Web che contiene il video che si intende scaricare e copiarne l’URL.  A questo punti una notifica di JDownloader ti avviserà del fatto che il link è stato catturato. Per avviare il download si dovrà evidenziare la  scheda Cattura collegamenti del programma e cliccare sul pulsante play collocato in alto a sinistra. In questo modo  il programma comincerà a scaricare il video dall’indirizzo che abbiamo selezionato

EstensioneVideo DownloadHelper (Google Chrome/Mozilla Firefox)

La procedura da seguire per scaricare video da Internet è praticamente la stessa su entrambi i browser: una volta individuato  il video online che si vuole salvare, si deve cliccare sull’icona di Video DownloadHelper (i pallini colorati in alto a destra) e successivamente  sul nome del file da prelevare. In alcuni casi il video può essere disponibile in vari formati e risoluzioni.

Servizio on-linePastiLink (pasty.link)

Per usarlo è sufficiente collegarsi alla pagina Web  del servizio e incollare l’indirizzo del video che si vuole scaricare nella barra collocata in alto . In automatico compariranno i vari formati del video che  si desidera scaricare

 

#come scaricare video da youtube

#come scaricare video da facebook

#come scaricare i video da Internet

Configurazione NAT su router CISCO (overload)

May 17th, 2017 No comments

Il NAT overload associa una lista di ip sulla rete interna (inside) all’unico IP dell’interfaccia esterna (outside). E’ la funzione di NAT più utilizzata, da abilitare quando si ha a disposizione un solo indirizzo IP pubblico, o comunque quando si vuole che tutti gli host si presentino su Internet sempre con lo stesso IP.

Supponiamo quindi di avere questo scenario:

Schermata 2017-05-17 alle 11.01.45

 

 

 

 

 

 

PC1 con indirizzo IP 192.168.0.2 sull’interfaccia e0 (DG: 192.168.0.1)

R1 con le seguente configurazione sulle interfacce:

f0/1 192.168.0.1

f 0/0 con IP pubblico verso Internet (Cloud1)

A questo pinto definiamo l’interfaccia inside (dove si trovano i PC della LAN)

R1(config)#interface fastEthernet 0/1

R1(config-if)#ip nat inside

e l’interfaccia outside (quella che si affaccia verso Internet)

R1(config)#interface fastEthernet 0/0

R1(config-if)#ip nat outside

Con il seguente comando invece diciamo di “nattare” tutto ciò che proviene dall’interfaccia inside e che coincide con l’access-list 1, utilizzando l’IP dell’interfaccia di uscita (overload)

R1(config)#ip nat inside source list 1 interface fastEthernet 0/0 overload

e infine creiamo l’access list per far passare il traffico proveniente dagli IP della LAN 192.168.0.0/24

R1(config)#access-list 1 permit 192.168.0.0 0.0.0.255

E magicamente

PC1> ping 8.8.8.8
84 bytes from 8.8.8.8 icmp_seq=1 ttl=45 time=96.761 ms
84 bytes from 8.8.8.8 icmp_seq=2 ttl=45 time=45.860 ms
84 bytes from 8.8.8.8 icmp_seq=3 ttl=45 time=31.472 ms

😉

Categories: Articolo Tecnico, Networking Tags:

Password recovery per gli switch Cisco

June 9th, 2015 No comments

Per eseguire il reset o per reimpostare la password di uno switch Cisco  si deve procedere nel seguente modo:

  • Spegnere lo switch, dopodiché tenere premuto il pulsante MODE sulla parte frontale sinistra e riattaccare il cavo di alimentazione. In base alla serie dello Switch, sono richiesti tempi diversi per la pressione del tasto mode.

Di seguito un elenco di riferimento:

 

Cisco Catalyst – serie Stato del LED e modalità di di rilascio del pulsante MODE
2900XL, 3500XL, 3550
Rilasciare il pulsante Mode dopo che il LED sopra la porta FastEthernet0/1 si spegne
2940, 2950
Rilasciare il pulsante Mode dopo circa 5 secondi dall’accensione, quando lo Status Led (STAT) si spegne. Quando il pulsante viene rilasciato, il LED di sistema (SYST) lampeggia con un colore arancio-giallo (ambra)
2960, 2970
Rilasciare il pulsante Mode quando il LED di sistema (SYST) lampeggia con un colore arancio-giallo (ambra) e poi rimane fisso sul verde. Non appena il pulsante viene rilasciato, il LED di sistema lampeggia con colore verde.
3560, 3750
Rilasciare il pulsante Mode dopo circa 15 secondi dall’accensione,  quando lo Status Led (STAT) diventa verde fisso. Non appena il pulsante viene rilasciato, il LED di sistema diventa verde fisso.

 

  • Se la procedura precedente viene completata correttamente, si accede alla modalità SWITCH ROM, come da esempio sottostante:

Boot Sector Filesystem (bs) installed, fsid: 2
Base ethernet MAC Address: 00:14:f2:d2:41:80
Xmodem file system is available.
The password-recovery mechanism is enabled.

The system has been interrupted prior to initializing the
flash filesystem. The following commands will initialize
the flash filesystem, and finish loading the operating
system software:

flash_init
boot

switch:

 

  • Inizializziamo la Flash con il comando flash_init:

switch:flash_init
Initializing Flash…
flashfs[0]: 5 files, 1 directories
flashfs[0]: 0 orphaned files, 0 orphaned directories
flashfs[0]: Total bytes: 15998976
flashfs[0]: Bytes used: 12282368
flashfs[0]: Bytes available: 3716608
flashfs[0]: flashfs fsck took 10 seconds.
…done Initializing Flash.

switch:

 

  • Visualizziamo i file memorizzati nella flash e cerchiamo i file di configurazione (di default si chiama config.text) con il comando dir flash:

switch:dir flash:
Directory of flash:/

2  -rwx  12272570                 c3560-ipservicesk9-mz.122-52.SE.bin
3  -rwx  684                           vlan.dat
4  -rwx  1938                         private-config.text
6  -rwx  1654                         config.text
7  -rwx  3096                         multiple-fs

3716608 bytes available (12282368 bytes used)

switch:

 

  • Rinominiamo config.text in config.old

switch:rename flash:config.text flash:config.old

Nota Bene:

se si vuole semplicemente cancellare tutta la configurazione, ossia resettare non solo la password ma l’intero switch, usiamo il comando delete flash:config.text

  • Verifichiamo che il file sia stato rinominato correttamente. Il comando dir flash: deve quindi mostrarci il file config.old. A questo punto digitiamo il comando boot per far ripartire lo switchNon appena lo switch si avvia, il prompt proporrà una configurazione iniziale guidata:

— System Configuration Dialog —

Would you like to enter the initial configuration dialog? [yes/no]: n
Switch>

 

  • A questo puntoi se si vuole recuperare la configurazione precedente, entriamo in “privileged mode” e copiamo il contenuto del vecchio file di configurazione sulla configurazione in esecuzione (running configuration) con il comando copy flash:config.old run

Switch>enable
Switch#copy flash:config.old run
Destination filename [running-config]?
1654 bytes copied in 9.647 secs (171 bytes/sec)
ARSCORESW1#

 

  • Se abbiamo seguito il passo precedente possiamo cambiare le password rimanendo in modalità privileged mode, altrimenti vi entriamo con il solito comando conf t. Dopo aver cambiato le pasword, salviamo la configurazione attuale sulla configurazione di startup:

Switch#configure terminal
Switch(config)#enable secret nuova_password
Switch(config)#line console 0
Switch(config-line)#password nuova_password

Switch(config-line)#end
Switch#copy run start
Destination filename [startup-config]?
Building configuration…
[OK]
0 bytes copied in 1.309 secs (0 bytes/sec)
Switch#

 

(articolo originale di  Alessio Carta)

Categories: Networking Tags: ,

Configurazione VLAN su Switch Cisco (IOS)

May 19th, 2015 No comments

Nei multilayerswitch Cisco una porta può funzionare alternativamente a layer 2 o a layer 3. Il default cambia da modello a modello. Il passaggio da layer 2 a layer 3 avviene con il comando “switchport” (layer 2) oppure “no switchport” (layer 3 ovvero “routed” sull’output di “show interface status”).

Una porta layer 2 funziona in tre modi

  • dynamic: il DTP, Dynamic Trunking Protocol, negozia se la porta è in access o in trunk mode. Questo è il default. Non usare.
  • access: passa una sola vlan untagged, comando “switchport mode access”
  • trunk: passano più vlan, comando “switchport mode trunk”

Alcuni comandi, sebbene possano essere inseriti in qualsiasi momento, diventano effettivi solo in certi stati dell’interfaccia: un esempio è il comando

switchport trunk native vlan X

diviene effettivo solo se la porta è in mode trunk.

Analogamente, il comando

switchport access vlan X

è efficace solo le porta in mode access.

 

Confronto tra HP Procurve e Cisco (configurazione VLAN)

Se la logica di fondo è la stessa, sono molto diverse le modalità di configurazione. In Hp non c’è bisogno di dire allo switch “questa porta è in access!, questa è in trunk!”. Basta dire questa vlan X è tagged sulla porta N, mentre quest’altra vlan Y è untagged sulla porta N. Implicito che ogni porta può avere una sola vlan untagged. In Hp, in una certa interfaccia escono solo le vlan esplicitamente configurate per farlo. (Con la parola “trunk” nel mondo HP ci si riferisce all’aggregazione di link fisici, che Cisco chiama “etherchannell”). Vediamo alcuni esempi confrontando le configurazioni.

Porta 25, con vlan 4 tagged, vlan 5 tagged, vlan 6 untagged.

vlan 4
tagged 25

vlan 5
tagged 25

vlan 6
untagged 25

 

In Cisco le cose cambiano molto. Quando una porta è in trunk, di default passano tutte le vlan configurate sullo switch, con la vlan 1 untagged: in altri termini quando una porta è in trunk è implicito il comando “switchport trunk native vlan 1”.

Cerchiamo di ottenere la stessa configurazione di prima: vlan 4 tagged, vlan 5 tagged, vlan 6 untagged.

interface fastethernet 2/11
switchport
switchport mode trunk
switchport trunk native vlan 6
end

Ora si vuole che da una certa if esca solo la vlan 6 untagged. In HP è semplicemente….

vlan 6
untagged 25

In Cisco invece

interface fastethernet2/11
switchport
switchport mode access
switchport access vlan 6

 

Categories: Articolo Tecnico, Networking Tags:

Configurazione rete su Windows

April 15th, 2014 No comments

Dopo aver spiegato come si configura la rete su Linux, ecco i passi per la configurazione di un indirizzo IP in ambiente WIndows

VoIP – debug e troubleshooting traffico SIP con ngrep

June 6th, 2013 No comments

http://ithelpblog.com/wp-content/uploads/2013/01/SIP1.pngCon questo articolo tecnico ritorniamo ad occuparci di VoIP e in particolare del troubleshooting del traffico SIP.

Il comando essenziale che dobbiamo utilizzare è “ngrep”.  Per installarlo su una macchian Ubuntu basta scrivere sul terminale

apt-get install ngrep

Vediamo ora la modalità di utilizzo direttamente con alcuni esempi:

Sniffare tutto il traffico SIP:

ngrep -qt -W byline port 5060
# ngrep -qt -W byline port 5060
interface: eth0 (192.168.0.0/255.255.255.0)
filter: (ip or ip6) and ( port 5060 )T 2013/04/27 05:59:09.541776 192.168.0.200:52018 -> 192.168.0.114:5060 [A]……T 2013/04/27 05:59:09.541837 192.168.0.200:52018 -> 192.168.0.114:5060 [AP]
REGISTER sip:openuctest.com SIP/2.0.
Via: SIP/2.0/TCP 192.168.0.200:36752;branch=z9hG4bK-d8754z-95798a09824c9c00-1—d8754z-;rport.
Max-Forwards: 70.
Contact: <sip:200@192.168.0.200:36752;rinstance=85aa8608b85349aa;transport=TCP>.
To: “200″<sip:200@openuctest.com>.
From: “200″<sip:200@openuctest.com>;tag=745f025a.
Call-ID: N2E0NDg0NTdlYmFmNTY2NjM0NGNmOWNkNDE1YWM0YmE..
CSeq: 1 REGISTER.
Expires: 3600.
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, NOTIFY, MESSAGE, SUBSCRIBE, INFO.
Supported: replaces.
User-Agent: Bria Professional release 2.4 stamp 49381.
Content-Length: 0.
.
T 2013/04/27 05:59:10.478656 192.168.0.114:5060 -> 192.168.0.200:52018 [AP]
SIP/2.0 408 Request timeout.
From: “200″<sip:200@openuctest.com>;tag=745f025a.
To: “200″<sip:200@openuctest.com>;tag=VmNa8r.
Call-Id: N2E0NDg0NTdlYmFmNTY2NjM0NGNmOWNkNDE1YWM0YmE..
Cseq: 1 REGISTER.
Via: SIP/2.0/TCP 192.168.0.200:36752;branch=z9hG4bK-d8754z-95798a09824c9c00-1—d8754z-;rport=52018.
Server: sipXecs/4.6.0 sipXecs/sipXproxy (Linux).
Content-Length: 0.
.T 2013/04/27 05:59:10.678860 192.168.0.200:52018 -> 192.168.0.114:5060 [A]
……

Sniffare e filtrare sull’indirizzo IP 192.168.0.200

ngrep -qt 192.168.0.200 -W byline port 5060

Sniffare e filtrare sull’utente “pippo”

ngrep -qt pippo -W byline port 5060

Sniffare e filtrare solo i pacchetti SIP con il metodo INVITE

ngrep -W byline -d eth0 INVITE

(articolo originale: http://ithelpblog.com/voice/troubleshooting-and-debug-voip-sip-by-ngrep-command/)

Aggiungo check funzionamento servizio SIP 5060:

nc -z -v -u <indirizzo IP> 5060

Configurazione rapida del bonding su Ubuntu

September 26th, 2012 No comments

Linux_BondingCon il termine “bonding” s’intende l’aggregazione di due o più interfacce di rete fisiche in una singola interfaccia virtuale, per ottenere tolleranza ai guasti e bilanciamento di carico.

Una buona pratica nella configurazione di un server, dotato di un minimo due interfacce di rete, prevede il collegamento a due *differenti* switch di accesso per garantire la ridondanza dei servizi erogati in caso di guasto di uno dei apparati di rete, come anche un uso più efficiente della banda disponibile.

Questo articolo tratta della configurazione rapida del bonding su sistemi Ubuntu in modalità active/backup. Questa modalità non prevede bilanciamento di carico, ma garantisce tolleranza ai guasti degli switch di accesso.

Entriamo ora nei dettagli della configurazione. Read more…